Applies To:
GroupID 9 and above
Issue Description:
This article applies when both the following conditions are met:
- When you try to connect to a messaging provider and get the error, “Messaging provider is not available. Please check settings.”
- When some kind of “Trusted Host” settings are defined in WinRM.
To verify this condition, go to PowerShell on the GroupID machine and run the command, winrm get winrm/config. In the command’s output, if the trusted host section has some values in it (as highlighted in the image below), then the second condition is also met.
Root Cause:
GroupID cannot connect with the messaging provider because Kerberos authentication is not enabled in GroupID Data Service.
Issue Resolution:
Follow these steps to resolve this issue in GroupID 9:
- Navigate to the location:
C:\Program Files\Imanami\GroupID 9.0\GroupIDDataService\Web.config - Open the file with Notepad++ and add the following line after line 28:
<add key="MessagingProviderAuthType" value="Kerberos" /> - Save the file and close it.
- Open command prompt and type "IISRESET".
- Also restart GroupIDapppool9 from the IIS console.
- Relaunch GroupID Management Console and test the messaging system connectivity. It should be working fine.